Linux Quimper

ASUS-NotebookSKU


(l'homme réparé) #1

Salut
Sur un X541UV (ASUS-NotebookSKU) j’avais installé une Ubuntu 16.04 il y a quelques temps en double bout
Il revient avec son disque plein par les log…
Ce sont essentiellement des lignes de ce type

pcieport 0000:00:1c.5: AER: Corrected error received: id=00e5pcieport 0000:00:1c.5: PCIe Bus Error: severity=Corrected, type=Physical Layer, id=00e5(Receiver ID)
pcieport 0000:00:1c.5: device [8086:9d15] error status/mask=00000001/00002000
pcieport 0000:00:1c.5: [ 0] Receiver Error (First)

qui renvoie je suppose à ce matériel

00:1c.5 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)

Faut-il croire qu’il y a un bug dans la wifi comme semble l’indiquer ce lien. J’ai désactivé la wifi et je n’ai plus le problème


Bon c’est pas la panacée un portable sans wifi :slight_smile:
Merci de vos conseils

ajout : je vois qu’il faut ajouter au grub

pci = noaer

qu’en penser ?


(l'homme réparé) #2

J’ai modifié le gruc en ajoutant pci=noaer à la ligne

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=noaer”

J’ai réactivé la carte wifi
La wifi semble fonctionner. Plus de message d’erreur
Est-ce la bonne solution ?
Merci de votre aide


(l'homme réparé) #3

A noter que le problème est le même avec le live de Ubuntu 18.04.1 avec la 4.15.0-33


(vincent) #4

C’est la bonne solution, comme expliqué ici :

[PCIE] If the PCIEAER kernel config parameter is
enabled, this kernel boot option can be used to
disable the use of PCIE advanced error reporting.

Avec ce paramètre dans Grub, tu diminues la verbosité des logs.


(l'homme réparé) #5

Si je comprends bien, je casse le thermomètre pour faire baisser la fièvre :slight_smile:


(vincent) #6

Il y a un problème avec la machine, à l’usage ?

Si tout fonctionne correctement, la solution noaer règle ton problème : le remplissage des logs.

Tu peux essayer de voir ce qui provoque ces erreurs en amont en désactivant différents trucs : nomsi (cf. ici, j’ai pas tout compris), pcie_aspm (augmente la consommation électrique – détails ici).


(l'homme réparé) #7

Dans le bios j’avais désactivé la carte wifi et le problème de log avait disparu
Maintenant l’ordi est reparti chez son propriétaire. S’il revient, je pourrai voir plus précisément
Merci de ton aide