Linux Quimper

Audio desync pendant un transcode avec ffmpeg

Coucou :slight_smile:

J’essaie d’utiliser subsonic pour streamer des vidéos via HTTP.
Seulement, quand j’essaie de lire une vidéo, la piste audio se désynchronise progressivement de la piste vidéo.

La ligne de commande ffmpeg utilisée par le serveur est la suivante (valeur par défaut) :

ffmpeg -ss %o -t %d -i %s -s %wx%h -v 0 -b:v %bk -maxrate %bk -bufsize 256k -flags -global_header -map 0:0 -map 0:%k -ac 2 -f mpegts -c:v libx264 -preset ultrafast -c:a aac -b:a 96k -strict -2 -threads 0 -copyts -

Où %b correspond au bitrate choisi dans les options.

Quelqu’un aurait une idée ?

Bonne année,
Bises à tou-te-s

Je ne sais pas si dans la dernière version de ffmpeg cette option est valable et de plus je ne sais pas comment elle fonctionne…
-async 1 : permet de synchroniser le son et la video

ajout : option obsolète faut utiliser aresample
https://ffmpeg.org/ffmpeg-filters.html#aresample-1