Linux Quimper

Blocage au démarrage

L’installation sur mon petit portable se déroule bien, le premier redémarrage aussi, puis voici le problème, qui se pose sur 3 noyaux différents, le 4.15.0.29, le 4.15.0.50, et même sur le 5.0.0, après installation de quelques logiciels, comme de la mise à jour de plus de 400 logiciels.

Qui a une idée ?

Ouch.
As tu pensé à retirer les options “slplash” et “quiet” du menu grub pour avoir plus d’info ? (touche “e” dans grub sur la ligne du kernel voulu)
Tu peux aussi ajouter les options “–verbose nosplash debug”. (attention “–” c’est deux tirets, pas un long tiret comme l’a mis en forme disourse)

la mise à jour de plus de 400 logiciels.

Laisse moi deviner : tu as dit “oui” à une mise à niveau complète quand Ubuntu te la proposé. Ça explique les “400 màj” et le bloquage au démarrage.

La plupart du temps c’est le driver proprio qu’il faut désinstaller/réinstaller, d’expérience. Le plus simple est de démarrer d’un live pour faire ça.

Fañch,
Je testerai à l’occasion ta proposition. Elle suppose quelques installations de logiciels ou une mise à jour. Je n’ai pas encore déterminé lequel des deux était en cause.
Actuellement, je m’en tiens à une installation basique ; je n’ose pas installer le moindre logiciel. Là aussi, il faudra voir.

Otyugh,
La première fois où cela s’est produit date d’environ 3 semaines. Depuis, j’ai fait “réparer” Windows 10 par Asus (qui fonctionne depuis sans problème). J’avais fait toute une série de choses pour tenter que mon ordinateur fonctionne “comme avant” : réinstallation de Linux, Clonezilla pour restituer Windows, ça n’a pas bien fonctionné, d’où le passage chez Asus.
Bref, les “400 mises à jour” sont peut-être en cause, mais surtout je soupçonne que, entre un matin où ça fonctionnait normalement, et l’après-midi où rien me fonctionnait plus, je soupçonne un probable mise à jour d’un logiciel ou d’un fichier en rapport avec les noyaux, lesquels ont fonctionné sans problème ni la moindre défaillance avant.

Quel logiciel propriétaire ?

Quel logiciel propriétaire ?
Y a pas un firmware proprio de CG qui traîne ? La plupart des mes
retours de ce genre étaient des problèmes avec nvidia lors d’un passage
de version de Ubuntu.

Après c’est moi qui joue aux devinettes, y a plein d’autres
possibilités… Yay.

Pas de carte graphique, juste le “chipset” Intel : « IGPU : Intel UHD Graphics 620 ».

Non, cela se fait dans le menu de boot grub directement. (touche “e”)

1 Like

Fañch,

J’ai pourtant désactivé la mise à jour, mais j’ai vu qu’il s’en est fait une lors d’une extinction. Blocage “habituel” au redémarrage.
J’ai testé ta méthode, voir l’écran :

Résultat :

Une autre idée ? Merci d’avance.
Comme on voit, il y a au moins une ligne de plus, la première.

Redémarrage sur une clé USB ; accès au fichier grub.cfg da,s /boot/grub pour le modifier et insérer ta méthode, soit 3 fois.
Résultat identique. Revoici l’affichage du grub sur “e” :

Pas d’idée précise, mais peux-tu ajouter un echo quelconque sous la ligne de l’initrd (la dernière, sur ta photo) afin de voir si le ramdisk est bien chargé ?

L’ordinateur est BLOQUÉ, totalement bloqué…
Seul reste possible l’appui de 4 secondes sur le bouton d’alimentation pour éteindre.
Aucune autre action possible…

Au prochain test, j’ajoute ton idée à celle de Fañch.

Rappel : toute mise à jour provoque ce blocage dès le démarrage.
Il n’y a pas de “Kernel panic”, d’ailleurs je n’ai jamais vu ça depuis que j’utilise Linux.

Je serai en déplacement toute la semaine prochaine, je serai obligé d’utiliser Windows !

peut-être voir avec une clé usb en live l’occupation de ta partition

Pas besoin de modifier le fichier avec un live, le but de la manip était juste de modifier temporairement un boot pour ajouter ces options et avoir plus de logs. (ca se fait avec la touche “e” puis on modifie les lignes, puis F10) ; ainsi ces modifs sont oubliés aux boot suivants. :wink:

Je n’ai pas de piste du coup.
Je note qu’un live fonctionne, la cause serait sur le initrd qui pourrait être mal buildé… (le initrd est rebuildé lors des mises à jour. Je peux pas l’expliquer ici, mais l’idée serait de se mettre en chroot (avec le /boot monté si il est séparé) sur le système installé et de faire un update-initramfs -u pour regénrer les fichier initrd.

Fanch.

J’essaye de répondre à toutes les propositions de tous ! Merci à tous.

NB : j’avais exploré le forum Ubuntu.fr, il n’y a rien sur mon problème. Il y a des tas de “blocages” et de propositions de déblocages d’icelles, mais encore faut-il pouvoir y faire quelque chose… Celles du noyau présuppose un blocage post-démarrage, ce qui n’est pas mon problème, puisque c’est pendant le démarrage que le blocage est total.

  • Fañch : la tentative de refaire l’initramfs ne fonctionne pas, y compris quand je suis dans son répertoires (/boot) et bine sûr en sudo.
    Je n’ai pas de /boot séparé, tout le système est dans sa partition, séparée de celle du /home.
    sudo update-initramfs -u donne :
    « update-initramfs is disabled since running on read-only media »

  • addikt1ve : j’ai rajouté la ligne que tu suggères, voir les 2 photos :


    r%C3%A9sultat
    Ton truc marche… mais toujours le même blocage.

Si ça peut vous donner des indications…

  • René : Gparted m’indique que /dev/sda5, hébergeant tout le système, 20 Go dont 7 seulement occupés.
    /dev/sda6 étant le /home.
    Avec Nautilus :
    /usr 3,4 Go
    /var 750 Mo
    le reste ne fait pas grand chose.

Tu étais bien en chroot à ce stade ?

cf. Ubuntu Linux chroot guide

Mad eo, met muioc’h e oa e galleg.

il y a aussi : chroot [Wiki ubuntu-fr] qui est en français, c’est tout de même plus aisé à comprendre que 1) anglais ; 2) chroot.
Et j’en ai trouvé d’autres en français. Merci quand même.

Chroot exécuté pour pouvoir faire le “update-initramfs -u”, pas d’affichage à la ligne suivante : succès. C’est un peu long. C’est la partition /dev/sda5 qui a été “chrootée”, où se trouve le système Linux.
Au redémarrage suivant, après démontage, aucun changement :

  • démarrage sur “4.15.0.50 generic” : écran noir ;
  • démarrage sur “4.15.0.50 generic (recovery mode)” j’ai à nouveau l’affichage des deux lignes “Chargement de Linux …” et “Chargement du disque mémoire initial”.

J’en suis toujours au même point.