Combien de temps ... pour installer Ubuntu ?

Bonne question, « je vous remercie de me l’avoir posée ».

Comme il y a plusieurs phases possibles, et des problèmes ou incidents possibles pour cause de matériels plus ou moins bizarres, spéciaux ou exotiques dans l’ordinateur, voyons cela de plus près dans un cas ‹ simple ›.

La machine en cause est un ordinateur de bureau, Pentium IV, disque dur SATA 80 Go (hdparm : 50 Mo/sec), carte graphique ATI Radeon 9600 SE (AGP 8X) DVI pour un écran TFT ; carte Ethernet 10/100 Mbits ; lecteur de DVD 16X. Je pense que le reste est ici sans importance.

Le disque dur est déjà partitionné pour :
sda6 : swap
sda7 : /
sda8 : /home.
La distribution est une Kubuntu Feisty Fawn 7,04.

Au lieu de fournir les heures et de vous laisser débrouiller pour faire des calculs sexagésimaux (non, pas de sexe là-dedans, seulement un compte par 60), je partirai du temps zéro. Accessoirement, je laisse pudiquement dans l’ombre le moment de la journée (une soirée) où j’ai commis ce forfait, ou cet exploit : installer un distribution Linux moderne.

Temps zéro : démarrage du cédérom dans le lecteur de DVD.
Choix de la langue, de la taille de l’écran ; l’arrivée au bureau Kde ne dure que 3 à 4 minutes au maximum, disons 3.

3 min - Clic sur l’icône « Installer » au bureau Kde.
21 min – fin d’installation.
35 min – ‹ adept_updater › pour 117 mises à jour.
48 min – fin de mise à jour ; installation de logiciels non présents avec Adept : Firefox, Thunderbird ; quelques paramétrages avec Kcontrol.
58 min – utilisation de Firefox et Thunderbird, OpenOffice.

Temps total, environ une heure pour commencer à utiliser les logiciels courants.
Est-cee bon ?

Ah, pas si simple… Cette installation est en réalité la seconde tentative ! Une première installation s’était mal terminée, avec des erreurs. J’ai préféré tout recommencer. Donc le temps total est à rallonger d’environ 20 minutes.

Est-ce bien tout ?
Pas vraiment ! Quelques minutes, heures ou jours plus tard, on découvre que l’on n’a pas tel ou tel logiciel, « absolument indispensable » : Java, Flash player, Xsane, Digikam, VLC ; telle ‹ appliquette › comme le « Rapport météorologique » ou « l’horloge planétaire », etc. Chacun sa névrose et ses préférences. Plus les mises à jour, peu prenantes, cela fait quelques instants tous les 2-3 jours.

Entre temps, il a fallu « installer » la multifonction imprimante / scanner, ou tout autre périphérique, nécessitant parfois de longues recherches googlériennes, lorsque l’aide Ubuntu est défaillante.

Si l’on regarde le temps que prend l’installation du principal concurrent, il faut environ deux heures (dans mon souvenir) pour installer seulement le système d’exploitation. Certes, il contient un médiocre navigateur Internet, et le programme de courrier le plus visé in the world par les virus et autres malfaisances, lesquels programmes permettent toutefois de l’utiliser de suite. Pour une suite bureautique, il faut l’acheter fort cher ou être étudiant.

Ne parlons pas non plus des prix comparés, de la facilité des mises à jour, du contrôle de ce qui entre et sort de la machine à travers le ‹ firewall ›, de la gestion des droits sur le disque dur…
Certes, Linux est plus exigeant envers son utilisateur, mais il n’est pas plus compliqué --ni moins !-- que son rival.

NB : glxgears donne 1300 fps.

Tout à fait, j’ai passé une semaine à installer Windows XP Pro pour ma part :). Merci pour la piqûre de rappel !

glxgears te donne 1300 fps ?! J’ai la même carte graphique, j’utilise le pilote libre (qui ne permet pas l’accélération matérielle au passage, et utilise donc le processeur pour les calculs tridimensionnels) et je ne grimpe pas au-dessus des 700 fps ! Cela vient-il donc du processeur (AMD Athlon XP 2600+ cadencé à 2GHz, ce qui est souvent moins que les PIV qui montent à 3GHz) ?

la différence se ressent plus chez les utilisateurs confirmés

il n’existe pas de moyen d’accélérer la réinstallation de windows, des drivers de la carte-mère, ceux des périphériques, un CD par appareil, avec redémarrage a chaque étape

  • les programmes additionnels, a télécharger ou autres…

alors qu’buntu te permet de restaurer ta liste de “logiciels indispensables” en 2 secondes (hors temps de téléchargement, a condition de disposer d’une clé usb pour conserver 2 fichiers entre les formatages

mode d’emploi :
faire une copie du fichier sources.list sur la clé usb
lancer

dpkg --get-selections > liste_paquets.txt

et copier le fichier liste_paquets.txt sur la clé

réinstaller

restaurer le fichier sources.list
recopier le fichier liste_paquets.txt dans ton /home
et lancer

dpkg --set-selections < liste_paquets.txt

et voilà, tu as réinstallé tous tes programmes
si en plus, tu a une partition /home séparée que tu as pris la précaution de ne pas formater, même pas besoin de reconfigurer ton bureau et autres gadgets, tout est conservé

Oh, ça c’est sympa comme astuce ! Vraiment excellent, moi qui formate souvent tout en restant sur une distro debian-like… Merci :slight_smile: !

glxgears te donne 1300 fps ?! J'ai la même carte graphique, j'utilise le pilote libre (qui ne permet pas l'accélération [b]matérielle[/b] au passage, et utilise donc le processeur pour les calculs tridimensionnels) et je ne grimpe pas au-dessus des 700 fps ! Cela vient-il donc du processeur (AMD Athlon XP 2600+ cadencé à 2GHz, ce qui est souvent moins que les PIV qui montent à 3GHz) ?
Plutôt le pilote [b]non-libre[/b] ??? Si tu me dis comment vérifier la différence, je te tiens au courant. Le processeur ? Peut-être un peu, mais pas une différence de 50 % environ !
mode d'emploi : faire une copie du fichier sources.list sur la clé usb, lancer : [code]dpkg --get-selections > liste_paquets.txt[/code]
Utilisation accessoire de cette astuce : s'apercevoir qu'on a des tas de paquets à bord qui ne servent à rien ! Je vois plus de 40 lignes de : [b]xserver-xorg-video-XX[/b] dont un seul est [i]a priori[/i] utile : ATI (plus le générique -all, et aussi -kbd, -mouse, etc) ; par contre -sis, -cyrix et d'autres me paraissent ne faire que prendre de la place. Quelques autres programmes sur les 1476 lignes (chez moi) de ton fichier [b]liste_paquets.txt[/b] me semblent plutôt inutiles, ou plus que redondants. Extirpation(s) à faire avec précaution, puis régénérer [b]liste_paquets.txt[/b].

(Quelques dizaines de minutes plus tard)
Je viens d’enlever des « gnomeries », étant sous Kde, et 27 « xserver-xorg-video- », j’en ai gardé 1/2 douzaine en plus de l’ATI, par exemple le V4L, VMware… et après un redémarrage complet, ça marche toujours.

NB : j’ai utilisé Adept pour faire les suppressions, surtout pas de suppression directe.

c’est l’inconvénient des meta paquets (xserver-xorg-video-all dans ce cas)
la manip directe sur le fichier risque d’etre inutile, les paquets reviendront par dépendance

mieux vaut faire le ménage dans la distro avant d’exporter la liste

glxgears te donne 1300 fps ?! J'ai la même carte graphique, j'utilise le pilote libre (qui ne permet pas l'accélération [b]matérielle[/b] au passage, et utilise donc le processeur pour les calculs tridimensionnels) et je ne grimpe pas au-dessus des 700 fps ! Cela vient-il donc du processeur (AMD Athlon XP 2600+ cadencé à 2GHz, ce qui est souvent moins que les PIV qui montent à 3GHz) ?
Plutôt le pilote [b]non-libre[/b] ??? Si tu me dis comment vérifier la différence, je te tiens au courant. Le processeur ? Peut-être un peu, mais pas une différence de 50 % environ !
Bah dans ton xorg.conf, le driver utilisé est ati/radeon ou fglrx ?
  1. fragment du xorg.conf :

Section "Device" Identifier "ATI Technologies Inc RV350 AQ [Radeon 9600]" Driver "ati" BusID "PCI:1:0:0" EndSection
2) Suite au truc de Fuck Norris ci-dessus, j’ai dû enlever « un peu trop », du coup lorsque je veux utiliser adept_updater, au moment de passer en root, la boîte d’alerte accepte le mot de passe … mais est ensuite totalement inactive. Idem si je veux utiliser kdesu, etc., bref tout ce qui nécessite le mot de passe pour passer en root, en étant en mode graphique.
Qui saura me dire quoi faire ?
La situation n’est pas désespérée, « sudo su » fonctionne en console.
Problème résolu

  1. J’ai depuis bien du temps une répétition des touches qui me fait faire de nombreuses fautes. Comment rétablir la situation ? Je sais depuis quand cela se produit : lorsque j’ai pu passer mon écran en 1440 x 900 (voir message). Bien qeu je fasse attention, cela m’oblige à une quantité considérable de corrections, et de reprise de messages, comme par exemple celui-ci, car des répétitions m’échappent malgré mon attention et l’utilisation de la « Prévisualisation ».
    Problème NON résolu !
NB : unne réponse au point n° 2 est fortement souhaitée...
tu as essayé en console avec apt-get upgrade ou apt-get dist-upgrade ?

Oui ! Merci quand même !
Entre-temps j’avais cherché de mon côté sur Internet ; ça remarche !
Je fais des corrections dans mon message, erreur de code pour AddiKT1ve (ce n’était pas le bon ordinateur…)

Et pour la répétition excessive des touches ?? Pas d’idée ?

Et pour la répétition excessive des touches ?? Pas d'idée ?
Dans un xterm tu tapes la commande "xset -q" et tu vérifies les valeurs de «Keyboard Control:»: auto repeat delay: 500 repeat rate: 30.

Il doit avoir un endroit ou ça se configure dans KDE. Il y a (avait ?) ça sous Gnome donc KDE doit pouvoir le faire. Sinon c’est « xset -r 30 500 » à mettre dans son $HOME/.xsession .

Merci à saitMoh.

Voilà ce que j’ai :

cromdub@Muir:~$ xset -q Keyboard Control: auto repeat: on key click percent: 0 LED mask: 00000000 auto repeat delay: 250 repeat rate: 30 [ .. ] File paths: Config file: /etc/X11/xorg.conf Modules path: /usr/lib/xorg/modules Log file: /var/log/Xorg.0.log cromdub@Muir:~$
J’ai coupé des informations qui me paraissaient non pertinentes.
Le pire de ce problème est que ce n’est pas régulier ! Il y a des jours où la répétition est une plaie, et d’autres, comme aujourd’hui, où exactement les mêmes habitudes dactylographiques (depuis très, très longtemps !) ne donnent lieu à aucune répétition.
Bizarre, bizarre…

Touches à répétition… ça se répète.

Pas d’amélioration du problème :

  • j’ai fait un fichier ~/.xsession qui contient, dans le bon ordre des paramètres : xset r rate 500 30 ;
  • mais il n’est pas pris en compte au démarrage (persistance de ‹ 250 ›) ; il faut donc taper en console ces paramètres.

Existe-t-il un fichier système (dans /etc ou /usr ??) où ces données sont définies ? Ou bien serait-ce par exemple ~/.Xsession (avec une majuscule) ; ou encore autre chose ?

Pour ceux qui ont connu ce problème : c’est l’exaspération garantie ! Non seulement vous avez de temps à autre plusieurs fois la même lettre, mais en cas de correction, celle-ci peut également se répéter … plusieurs fois. Garder son calme dans ces conditions est difficile.

Qu’est-ce que tu utilise comme display manager (xdm, gdm, kdm, autres) ?

Avec xdm, le fichier ~/.xsession (qui doit être un script schell exécutable) est défini dans le script /etc/X11/Xsession . Faut cherchere les variables USERXSESSION et ALTUSERXSESSION.

Si ~/.xsession n’est pas exécuter tu peux essayer de créer un fichier ~/.xinitrc qui doit aussi être un script shell exécutable (voir man xinit) mais ça ne résoudra pas le problème si il apparaît dès le login. Dans ce cas il faut regarder les fichiers présents dans /etc/X11/[xgk]dm/ et trouver lequel modifier. Par exemple pour xdm, il y a le fichier /etc/X11/xdm/Xsetup :

[code]#!/bin/sh

$Id$

This script is run as root before showing login widget.

#xsetroot -solid rgb:8/8/8[/code]

Salut,

Etant sous Kubuntu, mon ‹ display manger › est kdm ; dans le fichier :
/etc/X11/default-display-manager il y a : /usr/bin/kdm

/etc/X11/Xsession existe, c’est une collection d’instructions bash

J’ai créé ~/.xsession et à tout hasard ~/.Xsession
Dans un premier essai c’étaient des fichiers textes simples ; puis je les ai rendus exécutables. Aucun effet sur mon problème !
Je n’ai pas de /etc/X11/[xgk]dm/
Mon répertoire /etc/X11 contient :
app-defaults/
cursors/
fonts/
xinit/
Xresources/
xserver/
xkb/
Xsession.d/
default-display-manager
rgb.txt
X (lien)
Xloadimage
xorg.conf
Xsession
Xsession.options
XvMCConfig
Xwrapper.config

Les lignes terminées par ‹ / › sont des répertoires, les autres des fichiers.
Il n’y a rien d’adéquat à mon problème dans tout ça.

Bref, pas de changement ; je n’ai pas trouvé où se trouvent les paramètres de xset « 250 30 » !
D’autres pistes ? Merci d’avance.

Aurais-je enfin trouvé ?
Après avoir envoyé ce message, pris d’un doute, je vais voir dans :
Menu K ; Réglages du système ; Clavier & souris ; Clavier.
Là se trouve : Activer la répétition des touches ; Délai ; vitesse.

Mais les valeurs indiquées n’étaient pas celles que me renvoyait xset…
Je ne me souviens pas avoir touché à ce panneau, sauf pour me mettre en simple clic sur la souris. Je laisse le double-clic aux amateurs doublement masochistes :

  • d’un certain système d’exploitation, non Linux, assez répandu ;
  • qui adore se torturer au double-clic.

Après deux jours, ça continue d’être correct, mes stupides problèmes de dactylographie à répétitions non désirées ont disparu.

On a rien inventé de mieux qu’une interface graphique, qui sait dans quel fichier écrire, finalement :D.

Je ne me souviens pas avoir touché à ce panneau, sauf pour me mettre en simple clic sur la souris. Je laisse le double-clic aux amateurs doublement masochistes : - d'un certain système d'exploitation, non Linux, assez répandu ; - qui adore se torturer au double-clic.
avec le simple clic, j'y arrive pas 1) j'ouvre le repertoire 2) je remonte dans l'arborescence en ralant parce que j'ai ouvert le rep au lieu de le selectionner 3) je le sélectionne enfin

ca multiplie les manip inutiles :stuck_out_tongue:
mais je suis peut être un boulet

Je ne me souviens pas avoir touché à ce panneau, sauf pour me mettre en simple clic sur la souris. Je laisse le double-clic aux amateurs doublement masochistes : - d'un certain système d'exploitation, non Linux, assez répandu ; - qui adore se torturer au double-clic.
avec le simple clic, j'y arrive pas 1) j'ouvre le repertoire 2) je remonte dans l'arborescence en ralant parce que j'ai ouvert le rep au lieu de le selectionner 3) je le sélectionne enfin

ca multiplie les manip inutiles :stuck_out_tongue:
mais je suis peut être un boulet


Je suis comme toi :).

Je ne comprends pas la difficulté que vous avez à utiliser le simple clic.

Il suffit de « pointer » avec le curseur de la souris, puis de faire UN clic.
Le double-clic est un choix et une habitude importés d’un autre système d’exploitation (qui nous exploite, oui) ; il nécessite une coordination neuro-musculaire supérieure à celle du simple clic. Il est plus difficile à apprendre et à pratiquer, par exemple pour les enfants (petits, AddiKT1ve tu es trop vieux !) ou les véritables néophytes ; au bout du compte, les habitués (du double) ne s’en rendent même plus compte !
Au fait, comment faites-vous dans une fenêtre Internet ? Au cas où vous n’auriez pas remarqué, c’est le simple clic !
C’était aussi le cas sous Unix et sous un ancien Mandrake, passé au double-clic sans doute pour les habitués de cet autre système mentionné ci-dessus.
J’ai décidé d’homogénéiser ma pratique, ordinateur comme Internet, sur le seul simple clic partout.

Mais chacun est libre de se donner de la difficulté, de se rudoyer, de se macérer, de se donner le cilice, de se fustiger, de se martyriser, et autres, avec le double-clic ou d’autres choses.

C’est mon opinion, et je la partage avec qui veut…