Linux Quimper

Driver

j’ai 1 ordi portable HP15ba064NF mémoire 12Go et 1To de stockage
j’ai installé ubuntu 18.04 LTS depuis le début de sa sortie qui a très bien fonctionné jusqu’à ce que je fasse une mise à jour et catastrophe plus de wifi ! .est ce qu’une personne possédant le même PC portable aurait 1 solution . (en fait c’est mon petit fils qui me l’a installé) sans doute 1 problème de driver c’est déjà arrivé et règlé par mon petit fils mais je ne l’ai pas toujours sur la main .
NB:en sachant que je suis complètement nul dans le domaine de l’informatique , je dis bien complètement NUL!
Merci à celui ou celle qui aura la patience de me lire et de me sortir de ce problème de Wifi

https://doc.ubuntu-fr.org/wifi

Lit totalement l’article avant manipulation. :slightly_smiling_face:

Ou je trouve le nom de la carte wifi et le chispset , excusez ma nullité

Salut @JFLR

  1. Ouvre un terminal :
    -> Menu -> Système -> Terminal

  2. Colle cette commande (+ entrée après) :
    lspci | grep -i net

Donne nous le retour, ici (copier-coller)

jflr@jflr-HP-Notebook:~$ lspci|grep-i net
grep-i : commande introuvable
jflr@jflr-HP-Notebook:~$ lspci | grep -i net
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL810xE PCI Express Fast Ethernet controller (rev 07)

Normal… C’est « grep -i » avec au moins un espace entre la commande « grep » et le commutateur, comme on l’appelle, « -i »…
Tel que tu l’as écrit, le « bash » comprend qu’on lui demande un truc nommé « grep-i »

De même, il est préférable de mettre un espace entre les commandes :
lspci | grep -i
même si le bash a bien compris qu’après lspci c’était le « tube » | puis une autre commande, qu’il n’a pas comprise car mal écrite.
Ne pas oublier encore un espace entre « -i » et « net »…

Piero l’avait pourtant bien écrite, avec plein d’espaces.

Voilà, ton éducation progresse…
Continue d’essayer !

est ce simplement :wireless network adapter le nom de la carte mais pas de chipset ouExpress Fast Ethernet controller (rev 07) le chipset :(rev 07)?
toute l’éducation a refaire !!! :sob:

La bonne façon de répondre à une demande d’une commande est celle-ci :

nvme@nvme:~$ lspci | grep -i net
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (4) I219-V (rev 21)
3a:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)
nvme@nvme:~$

Citer la commande et TOUT le résultat.

Chez toi tu as deux réponses (comme moi) :

  • Ethernet ; il n’y a jamais de problème, en principe
  • wireless network adapter ; ce dernier gère le Wifi.
    As-tu recopié toute la ligne ?

Si tu pouvais venir le mardi de 16 à 18 heures au Centre des Abeilles, ce serait préférable, nous pourrions t’aider matériellement.

tout d’abord merci michel ,
oui j’ai fait un copier/coller de l’ensemble commande et le résultat . actuellement je suis en filaire (ethernet il me semble , ) par contre quand je debranche le filaire je n’ai pas la liaison wifi et je remarque en bas de l’ecran il y a (un petit ecusson gris) le livepatch avec 1 point vert en filaire et 1 point rouge lorsque je debranche pour acceder à la wifi .c’est 1 remarque je viens de faire à l’ainstant

par contre je ne peux pas me deplacer

Salut,

J’avais lu un peu vite ton message « grep-i » collés ; la réponse est pourtant :
02:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter
concernant le Wifi.
C’est une puce Realtek, constructeur très courant, modèle RTL8723BE.

Puisque cette puce fonctionnait, il n’y a pas de raison claire qu’elle ne fonctionne plus.
Refaire une mise à jour ??
Vérifier s’il n’y a pas « paquets cassés » qui empêchent quelque chose de fonctionner normalement ?

Dans cette page :
https://doc.ubuntu-fr.org/wifi_liste_carte#realtek
il y a (j’ai abrégé) :
[RTL8723AE] « Reconnue par défaut. » Nécessite souvent de modifier les options du module rtl8723be/rtl8723ae
Renvois à ces pages :
RTL8723BE : wifi_realtek_rtl8192ce [Wiki ubuntu-fr]
Site Angristan : Résoudre les problèmes avec le module wifi RTL8723BE sous Linux | Angristan

  • modification du fichier de configuration par :
    echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf
    (le début de cette ligne, avant le tube « | » est ajouté dans le fichier rtl8723be.conf …)
  • sudo dpkg -i firmware-realtek_0.43_all.deb
    Problème : l’article date de 2015, mis à jour en 2017. Il y a peut-être un « firmware » plus récent.
  • La suite implique une compilation. Là je crois que cela dépasse largement tes connaissances actuelles… au risque de planter encore plus.

Vérification de paquets cassés, voir :
https://doc.ubuntu-fr.org/gestionnaire_de_mises_a_jour
À exécuter en console / terminal, pas en graphique ; tu vois tous les messages d’erreur.
sudo apt update && sudo apt full-upgrade -y

bonjour michel
je pense que je vais refaire une mise à jour et s’il le faut je ferai un gros appel « au secours » à mon petit fils ( infunMatique) je ne voudrais pas abuser de ta patience.Je vais retranscrire ton message pour le garder précieusement et l’étudier comme un gamin de CP . **un grand merci à toi ; je te tiens au courant de la remise à jour , on ne sait jamais

Michel j’ai fait une mise à jour mais pas de résultat ,en suite j’ai tenté les commandes linux/anglistan et pas plus de résultat ,pour l’ainstant je me calme je verrai demain . c’était pour te tenir au courant .salut ! Merci encore à toi à un de ces jours pour de nouveaux résultats. Je ne renonce pas (breton !)

Bonjour, dans un terminal vous pouvez tenter un

sudo rfkill unblock all
(tapez votre mot de passe en aveugle, après avoir fait ‹ ‹ entrée › ›)

et tester à nouveau votre carte wifi, avant de tout réinstaller.

PS : pouvez-vous (avant et après la commande ci-dessus) nous copier la réponse à
sudo rfkill list

pour que l’on vérifie avec vous ?

En complément à la commande de piero, qui peut pas faire de mal (je viens de voir un cas dans lequel rfkill ne débloquait pas la wifi, mais où ça passait quand ont le demandait à NM directement).

nmcli radio wifi on

(après si le bon driver n’est pas utilisé, c’est même pas la peine, j’ai du mal à suivre, y a eu beaucoup de choses dites et j’ai lu en diagonale.)

flr@jflr-HP-Notebook:~$ sudo rfkill list
[sudo] Mot de passe de jflr :
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
jflr@jflr-HP-Notebook:~$
si je ne me trompe pas la carte est active , non?

sudo rfkill unblock all : cette commande ne fait rien sans doute de fait que la carte n’est pas bloquée

je suppose

J’étais sur 18.04 LTS et il y a peu mon peut fils a rajouter Mate et le problème à commencer . la solution ne serait-elle pas tout simplement de réinstaller 18.04 LTS seulement . au vue de mon incompétence c’est peut-être farfelu . permettez moi de vous remercier vous tous qui essayer de me dépanner

C’est une solution. Une autre serait de passer à un point linux à venir pour montrer ta machine (y a beaucoup de choses simples à regarder qu’il est fastidieux à demander/verifier à distance). L’un comme l’autre marche.