Màj 14.4 vers 16.04.1 : ça s'est mal passé... :-/

Salut à tous !
J’ai sagement attendu la sortie de la 16.04.1 pour migrer sur XX via le Gestionnaire de MàJ ; en ligne.
Tout s’est apparemment bien passé sauf qu’au redémarrage, apparaît l’écran Xubuntu, puis, dans la seconde, un écran noir avec la mention (clignotante d’abord, puis fixe) : dev/sda2: clean, 382409/243941376 files 731285408/975741440 blocks.
Et ça reste coincé là.
J’ai ressayé plusieurs fois : le 1er nombre de fichiers ou blocs change parfois (mais pas systématiquement).
J’ai essayé le cd Boot Repair ; quand je lance l’outil, il me demande d’installer les dépôts 16.04.1 qui contiennent grub2 : 1. je ne sais pas où les trouver (je croyais que grub2 était natif dans les dépôts officiels depuis la v 9 KK ?), et 2. je ne saurais pas comment faire pour les installer.
Si on pouvait éviter d’avoir à réinstaller : je n’ai qu’une seule partition (je sais, je sais… :-[ ) rassemblant système et home.

Je n’ai aucune idée pour la réparation par contre si tu as un disque dur externe dont la capacité est suffisante pour sauvegarder ton home, tu effectues la sauvegarde en démarrant avec un Ubuntu live cd ou usb puis tu fais une installation de la 1604 en effaçant ton disque
Je sais c’est un peu bourrin mais ça a l’avantage de sauvegarder ton home que tu pourras transférer sur ton disque dur une fois la nouvelle installation de 1604 terminée :slight_smile:

Salut René !
C’est ce que je ferais en dernière extrémité si j’y étais contraint :frowning: ; mais ce qui me gêne, c’est que je n’aurai pas les droits pour copier les fichiers & dossiers cachés à l’identique, donc je vais perdre des configs en route, non ?
Et j’aimerais mieux essayer de régler le pb par une autre voie ; le fichier boot-info est ici. Si toi, ou quelque autre velu passant dans le coin y jetait un coup d’œil…

Coucou !
Alors, tu boot déjà ou pas ? est-ce que ton pc passe le grub ? je vais dire que oui parceque tu as mis “apparaît l’écran Xubuntu”…
Est-ce que tu as essayé de démarrer avec le kernel fallback (recovery mode) ? ( dans ton grub tu as plusieurs entrée normalement, essaye les toutes on sait jamais :slight_smile: )
Est-tu sur que ça reste bien coincé ? ( le fsck peu prendre du temps / Tu peux peut-être acceder au tty avec Ctrl+Alt+F2 )
Est-ce que tu as essayé d’enlever le “quiet splash” dans ton grub là : linux /boot/vmlinuz-4.4.0-31-generic root=UUID=24f503b8-8709-42cc-ae02-9b6093c90666 ro quiet splash $vt_handoff
Le fait d’enlever ça va afficher pleins de lignes au boot, et peut-être que l’une d’entres-elles sera utile…

Est-ce que tu as un liveCD/USB de dispo ? si oui est-ce que tu a essayé de lancer toi même un fsck pour voir si il se termine ( sudo fsck -y /dev/sda2 ) ?
Le fsck c’est en gros ton système qui vérifie l’état de ta partition, c’est géré dans /etc/fstab regarde https://doc.ubuntu-fr.org/verification_de_fichiers#un_fichier_importantetcfstab ainsi que https://doc.ubuntu-fr.org/mount_fstab#le_fichier_fstab
Tu vois que la dernière collone du fstab “pass” c’est elle qui gère le fsck au boot, essaye donc de la mettre à 0 comme déconseillé içi :

Une valeur de à 0 signifie qu’il n’y aura pas de vérification au démarrage (Déconseillé dans la plupart des cas).

Si jamais tu veux réinstaller et copier tes données, sache que normalement tu peux conserver les droits à l’identique :

-a, --archive identique à -dpR

-p
identique à --preserve=mode,ownership,timestamps
–preserve[=LISTE_ATTR]
préserver les attributts spécifiés (par défaut : mode,ownership,timestamps), et si possible les attributs additionels : links, all --no-preserve=LISTE_ATTR ne pas préserver les attributs spécifiés

-R, -r, --recursive
copier récursivement les répertoires

cf. la page de manuel de cp içi: http://pwet.fr/man/linux/commandes/cp

Voilou, désolé pour l’orthographe il est tard ;D
amuse toi bien !

PS: ton problème à l’air d’être connu par pleins de gens, cherche un peu sur google tu n’est pas seul…

Comme le dit xse, enleve les options “quiet splash” de ton grub pour voir les logs de boot mais aussi $vt_handoff qui peut poser souci pour l’affichage.

Pour cela, lorsque tu est dans le grub

[ul][li]place toi sur la ligne habituel “Ubuntu” du grub[/li]
[li]appuie sur “e” pour editer[/li]
[li]Retire les option quiet splash et $vt_handoff.[/li]
[li]appuie sur F10 pour lancer le boot[/li][/ul]

Je pencherai pour un souci du serveur X et pour ça il nous faudra aussi les logs /var/log/Xorg.0.log

Une fois démarré :

[ul][li]Appuie simultanément sur CTRL+ALT+F2 pour avoir une console avec login[/li]
[li]Identifie toi[/li]
[li]Renvoie nous une photo du resultat de la commande “tail -40 /var/log/Xorg.0.log”[/li][/ul]

Fanch

Merci à tous les 2 de vos réponses, mais j’ai sauvegardé mon home (enfin presque tout, j’en ai un peu perdu en route :frowning: ) et j’ai refait une install propre.
L’avantage, c’est que mon problème de carte-son que je traînais comme un boulet depuis des mois a été réglé ; de ce côté là, tous semble aller bien (croisons les doigts) !
Si vous avez un peu de temps, j’ai une petite question que j’ai posée ici.
Merci d’avance ! :wink:

Cool tant mieux si ça marche :smiley:

Pour ton conkyrc je peux pas te répondre sur le forum d’ubuntu j’ai pas de compte là-bas, mais je sais que la syntaxe du fichier de configuration à changée depuis la version 1.10, je pense que tu est bon pour réécrire ton fichier :slight_smile:
Il y a un script sensé mettre à jour la partie LUA içi si tu est motivé, je ne sais pas ce que ça vaut : https://github.com/brndnmtthws/conky/wiki/Convert-to-new-1.10-syntax
Tout dépent de ce qu’il y a dans ton conkyrc ::slight_smile: Je pense que ça peux fonctionner mais peut-être pas sans 2/3 modifications manuelles

Bon courage !