Linux Quimper

Panne (matérielle) du Wifi ?

(crom_dub) #1

Entre une extinction puis un réallumage, plus de Wifi, ce qui ne s’était pas produit depuis quatre ans sur mon Clevo 17 pouces.

À l’allumage, dans l’icône de la barre supérieure concernant le réseau, “Activer le réseau Wifi” n’est pas coché. Rien de plus après cochage.

Dans les forums Ubuntu, j’ai trouvé plein de trucs à faire, que voici.
Ça sent la panne matérielle ?

0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
dagda@dagda:~$ 


dagda@dagda:~$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="Ubuntu 16.04.4 LTS"
dagda@dagda:~$ lspci -k -nn | grep -A 3 -i net
02:00.0 Network controller [0280]: Intel Corporation Centrino Wireless-N 135 [8086:0892] (rev c4)
    Subsystem: Intel Corporation Centrino Wireless-N 135 BGN [8086:0062]
    Kernel driver in use: iwlwifi
    Kernel modules: iwlwifi

dagda@dagda:~$ sudo lshw -C network
  *-network DÉSACTIVÉ     
       description: Interface réseau sans fil
       produit: Centrino Wireless-N 135
       fabriquant: Intel Corporation
       identifiant matériel: 0
       information bus: pci@0000:02:00.0
       nom logique: wlp2s0
       version: c4
       numéro de série: 0c:d2:92:48:1f:cf
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.15.10-041510-generic firmware=18.168.6.1 latency=0 link=no multicast=yes wireless=IEEE 802.11
       ressources: irq:30 mémoire:f7d00000-f7d01fff

lsmod :

cfg80211              622592  3 iwlwifi,mac80211,iwldvm

dagda@dagda:~$ cat  /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback
dagda@dagda:~$ 

dagda@dagda:~$ nmcli connection show
NOM                  UUID                                  TYPE             PÉRIPHÉRIQUE 
Connexion Wi-Fi 1    76f5a180-df57-4feb-8d82-bac42bf6df8d  802-11-wireless  --           
Connexion filaire 1  ff7ee08b-e019-325e-86fb-727fc807e32e  802-3-ethernet   --           
dagda@dagda:~$ 
(Otyugh) #2
Hard blocked: yes
Ben ça sent surtout le switch matériel :o

Je m’étais déjà fait avoir, t’as bien regardé qu’y a pas une combinaison de touche ou un petit “lock” planqué quelque part pour la wifi ? Me souviens avoir essayé 20 minute des choses pour m’apercevoir qu’y avait un petit “on/off” de wifi planqué é_è

Sinon je regarderai dans l’uefi pour vérifier que c’est pas désactivé (mais y a pas de raison), puis ensuite démonter voir si tout est bien branché (mais à ce point je commencerai à désespérer et commander une clé USB/wif à 15€i).

(crom_dub) #3

Il n’y a aucun interrupteur matériel…
N’ayant jamais utilisé Fn + F11 j’avais oublié ce commutateur logiciel.
Merci de m’y avoir fait penser !Ouf !