Linux Quimper

[Résolu]Problème d'accès au forum

Négatif, TOR n’est pas le problème. (c’est même un solution de contournement).

Fañch,

Comment t’envoyer mon adresse IP publique par message privé ?
Merci d’avance.
Est-ce par « message direct » quand je clique sur ton image ?

Otuygh,

Justement, je n’accède au forum que par contournement, comme le dit Fañch, grâce à TOR.

Oui en MP sur le forum (je suppose qu’il faut cliquer sur mon profile…) ou par mail sur contact at linuxquimper org

Bien reçu ton ip. J’ai mis en place un outil d’analyse. :face_with_monocle:
Peux tu faire une nouvelle tentative sur l’adresse suivante ? (c’est normal que ça marche pas, mais j’aurai plus d’info). Et me prévenir.
https://check.qth.fr

Merci.

PS : Tu peux répondre directement à cette discussion en répondant au message de notification du forum. Ca ajoutera ta réponse au fil de discussion. :smiley:

Fañch,
Depuis Firefox, aucune connexion possible, comme d’habitude.

Avec le site QTH sous TOR, résultat :
Your IP address : 171.25.193.77
Your hostname : 171.25.193.77
Your agent : Mozilla/5.0 (Windows NT 6.1; rv:60.0) Gecko/20100101 Firefox/60.0
Time : 2019-07-01 20:16:17 (UNIX : 1562004977)

Su des conseils --je ne sais plus de qui-- j’avais changé le DNS, qui est :
80.67.169.12, 80.67.169.40, 80.67.188.188
Ça n’avait rien arrangé…

1 J'aime

Merci, j’ai quelques éléments là. Ton traffic n’arrive même jusqu’a mes VM, mais arrive sur l’hyperviseur. Et chose très étrange, je reçois ta requête 3 fois au lieu d’une, et l’une provient d’un autre routeur différent.
Je vais investiguer et te tiens au jus dans les jours à venir.

Passur que ça aide, mais c’est quoi le retour de
curl -s -o /dev/null -D- "https://forum.linuxquimper.org/t/probleme-dacces-au-forum/4067/11"
pour toi ?

1 J'aime

Pour info,voici ce que reçoit l’hyperviseur : à gauche une requête qui obtient une réponse (page qui charge), à droite, la requête de Michel pose souci (timeout). 46.105… étant le serveur.

.
.
.
.
.
EDIT 0h50 ce 02/07/2019 : Je viens de voir que tu attaques en TLS1 qui est deprecated. Je viens de le retirer des protocoles proposés par le serveur (j’ai aussi changé les ciphers) https://forum.linuxquimper.org . Est-ce mieux ?

1 J'aime

Otyugh,
Attente longue (une minute ?) puis rien.

Fañch,
Accès sans problème par TOR à ton lien https://forum.linuxquimper.org/ ; par contre depuis Firefox, toujours pareil : rien à faire, « Le délai d’attente est dépassé. »

TLS1 : que faire ? Je n’ai rien trouvé dans les paramètres de Firefox.

Pour désactiver TLS1 dans Firefox :

(cf. Turn Off SSL 3.0 and TLS 1.0 in Your Browser - SSL.com)

Addikt1ve,
Vu, exécuté passage à 2, merci.
Pas de changement.

Sorcellerie ! :scream:

Et t’as pas de souci avec d’autres sites en https sinon ?

Le fait que curl retourne rien est archi bizarre aussi. C’est genre tu te fais ignorer quoi O.o
Vu que tu disais que parfois ça passe par tor, essaye aussi :
torify curl -s -o /dev/null -D- "https://forum.linuxquimper.org/t/probleme-dacces-au-forum/4067/11"

Non :

La requête timeout, donc curl ne reçoit pas de réponse.

Otyugh,
AUCUN autre lien URL ne pose problème… Exclusivement le forum Linux Quimper !

nvme@nvme:~$ torify curl -s -o /dev/null -D- “Problème d'accès au forum
HTTP/2 200
server: nginx/1.10.3
date: Tue, 02 Jul 2019 16:57:34 GMT
content-type: text/html; charset=utf-8
vary: Accept-Encoding
x-frame-options: SAMEORIGIN
x-xss-protection: 1; mode=block
x-content-type-options: nosniff
x-download-options: noopen
x-permitted-cross-domain-policies: none
referrer-policy: strict-origin-when-cross-origin
x-discourse-route: topics/show
last-modified: Tue, 02 Jul 2019 15:00:53 GMT
cache-control: no-cache
x-request-id: 40fcbee5-744a-4996-83b3-f3a4d12ec1a0
x-runtime: 0.104227
x-discourse-trackview: 1
expires: Tue, 02 Jul 2019 16:57:33 GMT

nvme@nvme:~$

La requete obtient un timeout avec son IP, et un 200 via TOR.

Pour moi la comparaison de tes deux curl démontrent que ton IP est blacklisté. Amha.
Ça peut pas être un problème de requête avec curl, si ?

La requete arrive bien sur le serveur, le client fait un hello et le serveur lui répond plusieurs ACK. Il n’y a donc pour moi pas de blacklist. Par contre, le serveur n’envoie jamais de “server hello”… Pourquoi…

Michel, je viens de désactiver SSLH, le principal suspect.
Est-ce ok pour toi ?

Fañch,

Étonnant : ça marche ! :smiley:
(avec Firefox)
Est-ce que ça t’apprend quelques chose ?

1 J'aime

Je m’en doutais. je ne saurais pas pourquoi ça ne fonctionne pas avec SSLH.

1 J'aime

Merci à tous, surtout Fañch.
Je mets en “Résolu”.

1 J'aime