Linux Quimper

Urgent : Cherche sur Quimper un PC sous ouinouin pour dépannage imprimante

(nicole) #1

Bonjour bonjour,

Je viens d’acheter une imprimante laser couleur Samsung CLP-360 réputée
pour bien fonctionner sous nux avec le pilote foo2zjs.

Seulement voilà, dès le déballage-installation-mise sous tension de la
bête. Le voyant d’état s’allume rouge, ce qui signifie d’après le
manuel que “l’appareil s’est arrêté à la suite d’une erreur sévère”. On
est donc bien dans le hard pas dans le soft n’est-ce pas ? Mais
l’assistance Samsung contactée (après être passée par le revendeur
CDiscount) me répond au bout de 48h d’installer le pilote ouindoze dans
le PC pour lire le code d’erreur renvoyé par la machine pour dire
keskivapa.

  • Mais je suis sous Linux Madame,
  • On s’occupe pas de l’assistance Linux, trouvez un PC Windows pour
    nous donner le code d’erreur pour pouvoir vous répondre.

Bon j’ai compris que je ne pourrai pas leur renvoyer la bécane (ce que
je suis certaine de devoir faire in fine) avant de leur avoir donné ce
foutu code :frowning: donc je cherche quelqu’un qui aurait encore, sous l’effet
d’une extrême distraction que je lui pardonne d’avance, un PC sous
ouindoze à sa disposition sur quimper ou environs, portable de
préférence pour m’éviter de trimballer l’imprimante. (Je promets de
désinstaller le crincrin après la manip).

Installer winemu ? hem pas sûre que ça marche : seul le
répertoire /linux (avec des conneries java dedans) du CDROM apparait
dans l’arborescence… Je n’ai pas touché un ouidoze depuis 1997 pour
cause d’allergie incurable. Mon desktop est sous Gentoo et le portable
sous Debian.

Merci bras !

(vincent) #2

Bonjour,

Le driver Linux te donnera probablement le même code d’erreur (ou assimilé) : consulte le journal en tapant “dmesg” dans un terminal. Si tu n’arrives pas à lire la sortie toi-même, poste-la ici pour qu’on te file un coup de patte :slight_smile:

(nicole) #3

Merci Vincent. Le Driver Linux ? le fichier .ppd de cups pour cette imprimante veux-tu dire ? Le manuel parle bien d’un “Unified Driver Configurator”
http://downloadcenter.samsung.com/content/UM/201312/20131227165941500/FR/French/French/manual/start_basic.htm
avec apparemment plein d’utilitaires. Je l’ai installé mais il ne donne rien de plus que le pilote foo2zjs avec la différence qu’il n’est pas open source et une licence proprio. De plus pour la fonction du voyant d’état de l’imprimante, c’est bien précisé “Disponible pour les utilisateurs de Windows.” :
http://downloadcenter.samsung.com/content/UM/201312/20131227165941500/FR/French/French/manual/start_basic.htm

Dans cups > Maintenance > Imprimer la page de test de l’imprimante ; j’obtiens bien une erreur sans description et quand je lance l’impression d’une page de test cups j’ai une tâche active qui s’affiche, l’imprimante se dit en cours d’impression, comme d’hab quand un imprimante n’est pas branchée ou allumée. Ce qui me semble normal puisque celle-ci se met en erreur dès l’allumage.

Voilà le dmesg qui en résulte :

[ 1422.770091] hub 2-0:1.0: port 2, status 0101, change 0001, 12 Mb/s
[ 1422.874037] hub 2-0:1.0: debounce: port 2: total 100ms stable 100ms status 0x101
[ 1422.976052] usb 2-2: new full-speed USB device number 2 using uhci_hcd
[ 1422.980028] usb 2-2: uhci_result_common: failed with status 440000
[ 1422.984012] usb 2-2: uhci_result_common: failed with status 440000
[ 1422.988012] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.090046] usb 2-2: device descriptor read/64, error -71
[ 1423.194996] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.198978] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.202988] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.305071] usb 2-2: device descriptor read/64, error -71
[ 1423.508044] usb 2-2: new full-speed USB device number 3 using uhci_hcd
[ 1423.511948] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.515926] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.519923] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.621050] usb 2-2: device descriptor read/64, error -71
[ 1423.725908] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.729890] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.733888] usb 2-2: uhci_result_common: failed with status 440000
[ 1423.835023] usb 2-2: device descriptor read/64, error -71
[ 1424.038038] usb 2-2: new full-speed USB device number 4 using uhci_hcd
[ 1424.041850] usb 2-2: uhci_result_common: failed with status 440000
[ 1424.245807] usb 2-2: uhci_result_common: failed with status 440000
[ 1424.446026] usb 2-2: device not accepting address 4, error -71
[ 1424.548041] usb 2-2: new full-speed USB device number 5 using uhci_hcd
[ 1424.551766] usb 2-2: uhci_result_common: failed with status 440000
[ 1424.755738] usb 2-2: uhci_result_common: failed with status 440000
[ 1424.956031] usb 2-2: device not accepting address 5, error -71
[ 1424.956063] hub 2-0:1.0: unable to enumerate USB device on port 2
[ 1424.956071] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0004

Je doute fort que ces statuts et codes d’erreur soient envoyés par l’imprimante, pour moi c’est du UDEV. D’ailleurs voilà ce que donne un lsusb :

nicole@Deleuze /tmp $ lsusb Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 002: ID 15d9:0a4c Trust International B.V. USB+PS/2 Optical Mouse

Comme je disais sur MDL, j’ai acheté cette imprimante en urgence car la dernière vielle vient de ma lâcher et que je n’ai pas le temps d’en réparer une de mon stock de vielles brouettes (une bonne dizaine mais bien meilleures que les merdes qu’on nous vend maintenant), c’est pas pour construire des virtual machine ou des cathédrales, mais trouver un PC sous windows - si ça existe encore sur Quimper - comme le demande ce SAV buté pour lui donner le code qu’il réclame et lui faire reconnaître qu’ils m’ont livré une machine défectueuse et qu’il doivent accepter le retour. Non mais, c’est pas à une retraitée du SAV de chez Canon (entre autres) qu’il vont raconter des salades ces marchands du temple :wink:

(nicole) #4

Re.

J’ai éteint la machine, refait un dmesg pour noter la dernière ligne, je rallume la machine et refais un dmesg dès qu’elle se met en erreur et voilà la suite :

[ 6079.703779] hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0004 [ 6079.703795] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001003 0 ACK POWER sig=se0 CSC CONNECT [ 6079.703807] hub 1-0:1.0: port 2, status 0501, change 0001, 480 Mb/s [ 6079.807020] hub 1-0:1.0: debounce: port 2: total 100ms stable 100ms status 0x100 [ 6085.787061] hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0004 [ 6085.787075] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001803 0 ACK POWER sig=j CSC CONNECT [ 6085.787086] hub 1-0:1.0: port 2, status 0501, change 0001, 480 Mb/s [ 6085.813051] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001002 0 ACK POWER sig=se0 CSC [ 6085.839050] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 001803 0 ACK POWER sig=j CSC CONNECT [ 6085.943042] hub 1-0:1.0: debounce: port 2: total 150ms stable 100ms status 0x501 [ 6085.994228] ehci_hcd 0000:00:1d.7: port 2 full speed --> companion [ 6085.994237] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 003801 0 ACK POWER OWNER sig=j CONNECT [ 6085.994245] hub 1-0:1.0: port 2 not reset yet, waiting 50ms [ 6086.000016] usb usb2: wakeup_rh (auto-start) [ 6086.045044] ehci_hcd 0000:00:1d.7: GetStatus port:2 status 003002 0 ACK POWER OWNER sig=se0 CSC [ 6086.045076] hub 1-0:1.0: state 7 ports 8 chg 0000 evt 0004 [ 6086.045083] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0004 [ 6086.045090] uhci_hcd 0000:00:1d.0: port 2 portsc 0093,00 [ 6086.045097] hub 2-0:1.0: port 2, status 0101, change 0001, 12 Mb/s [ 6086.149023] hub 2-0:1.0: debounce: port 2: total 100ms stable 100ms status 0x101 [ 6086.251024] usb 2-2: new full-speed USB device number 6 using uhci_hcd [ 6086.254999] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.258988] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.262985] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.365023] usb 2-2: device descriptor read/64, error -71 [ 6086.469972] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.473957] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.477966] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.580036] usb 2-2: device descriptor read/64, error -71 [ 6086.783060] usb 2-2: new full-speed USB device number 7 using uhci_hcd [ 6086.786918] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.790912] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.794913] usb 2-2: uhci_result_common: failed with status 440000 [ 6086.896064] usb 2-2: device descriptor read/64, error -71 [ 6087.000034] usb 2-2: uhci_result_common: failed with status 440000 [ 6087.003866] usb 2-2: uhci_result_common: failed with status 440000 [ 6087.007865] usb 2-2: uhci_result_common: failed with status 440000 [ 6087.109022] usb 2-2: device descriptor read/64, error -71 [ 6087.312050] usb 2-2: new full-speed USB device number 8 using uhci_hcd [ 6087.315824] usb 2-2: uhci_result_common: failed with status 440000 [ 6087.519794] usb 2-2: uhci_result_common: failed with status 440000 [ 6087.720024] usb 2-2: device not accepting address 8, error -71 [ 6087.823033] usb 2-2: new full-speed USB device number 9 using uhci_hcd [ 6087.826738] usb 2-2: uhci_result_common: failed with status 440000 [ 6088.030707] usb 2-2: uhci_result_common: failed with status 440000 [ 6088.231037] usb 2-2: device not accepting address 9, error -71 [ 6088.231066] hub 2-0:1.0: unable to enumerate USB device on port 2 [ 6088.231074] hub 2-0:1.0: state 7 ports 2 chg 0000 evt 0004

Reste à traduire en Samsung-Windows error-71 et status 440000 ?

(vincent) #5

Ça y est, je suis dépassé :slight_smile:
Je passe mon tour…

[EDIT]
Mmh, d’après ce thread [http://ubuntuforums.org/showthread.php?t=797789] le problème pourrait venir de la config USB. Essaie :

sudo echo -1 >/sys/module/usbcore/parameters/autosuspend
(nicole) #6

Et moi j’ai demandé un bon de retour au vendeur. C’est quand même pas au client de dépanner le matériel qu’il achète >:(

[EDIT]

Eh ben voilà ! il suffisait de menacer. Avant de la débrancher pour la remballer, j’essaie une dernière fois de rallumer l’imprimante, et là elle marche la bourique, au lieu de se mettre en défaut tout de suite, elle fait ses salamalek et se met met en gentiment en attente. J’imprime une page de test, la qualité est pas terrible mais ça c’est l’humidité du papier dans la cassette depuis plusieurs jours et mon bureau n’est chauffé que par le soleil. C’est vrai qu’il y a un rayon là, c’est pas ça quand même :-
C’est susceptible ces bêtes là j’espère qu’elle va pas me faire ça tous les 4 matins :-[